SOPHY is built to work in the following desktop and mobile web browsers. It may work in other browsers but these are not officially supported.

Web browser support for SOPHY:

  • Firefox (latest version)
  • Chrome (latest version)
  • Safari 10 and later
  • Microsoft Edge (version 15 and later)
  • Internet Explorer 11 and later

If you are using an outdated browser, you can upgrade it here. If you find issues in any of our supported browsers, please let us know by using our messenger.

Did this answer your question?